gpg_agent with python-gnupg

Richard Ulrich ricul77 at
Fri Dec 19 16:29:28 CET 2014


I have a python script that signs a message using python-gnupg:

import gnupg
gpg = gnupg.GPG(gnupghome='~/.gnupg', use_agent=True)
qrInfoString = 'some long\nmessage\nspanning multiple\nlines'
qrInfoString = str(gpg.sign(qrInfoString, keyid='E8401492!',
clearsign=True, binary=False))

The last time I tried it about half a year ago, it worked. Since then
with upgrading ubuntu there was a change in behavior of the gpg_agent. I
can't remember the details, but it also affected enigform.

I'm not sure, but I suspect gpg doesn't get the info about the
How can I verify my assumption, and if true, how can I pass the
agent_info to python-gnupg?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: This is a digitally signed message part
URL: </pipermail/attachments/20141219/5f6128e0/attachment.sig>

More information about the Gnupg-users mailing list