Error "Need the secret key to do this" Encountered During adduid command in UNIX

Jim Ernst jernst at
Mon Feb 10 20:28:11 CET 2014

Hi Daniel - thank you for the information... so using --export-secret-keys does the complete key, including both public and secret?  The key I had imported and then tried to use adduid on was created using just --export.  I could not use adduid on the new machine I had imported too;  sounds like using this --export-secret-keys would have solved the issue.  Is there any special syntax on the --import when importing a file that was exported using --export-secret-keys?

Jim Ernst
jernst at

-----Original Message-----
From: Daniel Kahn Gillmor [mailto:dkg at]
Sent: Monday, February 10, 2014 2:05 PM
To: Jim Ernst; GnuPG Users
Subject: Re: Error "Need the secret key to do this" Encountered During adduid command in UNIX

On 02/10/2014 08:44 AM, Jim Ernst wrote:

> After looking at it further, I did wonder whether or not it was a result of exporting the file off of one UNIX machine and importing it onto another (again, using just --export). Would you know if movement like that between machines should create an issue? I was figuring the key could be exported from one UNIX machine and imported to another, but I did not know if the machine ID was part of the key.

--export only emits the public keys, not the secret keys.  You'd want --export-secret-keys if you wanted to transfer the secret keys as well.



CONFIDENTIALITY NOTICE: The information in this e-mail message and any attachments may contain privileged, confidential or proprietary information, including confidential health information, protected by applicable Federal or state laws. Such information is intended only for the recipient named above. If you are not the intended recipient, please notify the sender immediately, and take notice that any use, disclosure or distribution of such information is prohibited by law.

More information about the Gnupg-users mailing list