Why the software is crap

david at gbenet.com david at gbenet.com
Fri Nov 14 18:30:19 CET 2014

On 14/11/14 13:38, Gabriel Niebler wrote:
> Dear David, dear fellow GnuPG users,
> this conversation made me curious, so I tried to do it myself. Here's
> what I did on my work laptop, just now, five minutes ago (in my home dir):
> $ rm -rf .gnupg
> $ scp -r ${myfileserver}:${pathtobackupsfromOTHERlaptop}/.gnupg/ .
> (...)
> $ rm .gnupg/random_seed
> $ echo "My hovercraft is full of fish, but I tell everyone they're
> eels." > my_big_secret.txt
> $ gpg --encrypt --recipient 0x65A3F1CC8303C0EC my_big_secret.txt
> $ rm my_big_secret.txt
> $ gpg --decrypt my_big_secret.txt.gpg
> You need a passphrase to unlock the secret key for
> user: "Gabriel Niebler <gabriel.niebler at gmail.com>"
> 2048-bit RSA key, ID 0x65A3F1CC8303C0EC, created 2014-03-16
>          (subkey on main key ID 0xD05AF6C786CB34F4)
> gpg: encrypted with 2048-bit RSA key, ID 0x65A3F1CC8303C0EC, created
> 2014-03-16
>       "Gabriel Niebler <gabriel.niebler at gmail.com>"
> My hovercraft is full of fish, but I tell everyone they're eels.
> So this all worked and the fact that this message is signed (using
> Enigmail/Thunderbird) is further proof that the method worked for me.
> Now that we have established that simply copying over your .gnupg
> directory from one machine to another and deleting random_seed does
> indeed produce the desired result for some people, maybe you can walk
> us through exactly what you did and we'll see if we can't figure out
> what the problem is. I suggest copying and pasting shell commands and
> their output verbatim.
> If you do not want to bother the rest of the list with this you are
> welcome to send mails directly to me. I am not an expert, but I'm
> willing to help you.
> Best
> gabe
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at gnupg.org
> http://lists.gnupg.org/mailman/listinfo/gnupg-users

I tried this with my keys - it was successful - I even imported my keys successfully but I
get the same error as before.


“See the sanity of the man! No gods, no angels, no demons, no body. Nothing of the
kind.Stern, sane,every brain-cell perfect and complete even at the moment of death. No
delusion.” https://linuxcounter.net/user/512854.html - http://gbenet.com

More information about the Gnupg-users mailing list