Installing GPA

Werner Koch wk at
Sat Sep 6 10:27:41 CEST 2014

On Fri,  5 Sep 2014 14:51, mac3iii at said:

> vistas in Gnupg.  Installing the newest GPA was a bit of a challenge
> but well worth it.  With Gnupg-2.0.26 installed I was never able to

You mean GPA 0.9.5?

> get GPA fully working.  Errors such as: relocation error: gpa: symbol
> gpgme_op_spawn, version GPGME_1.1 not defined in file

GPA 0.9.5 requires gpgme version 1.5.0 but you better use 1.5.1.  Now it
seems that you build agains that gpgme versions but your shared library
setup is not correct and thus GPA uses at runtime gpgme 1.4.x version.
THis leads to the the error.

In case you installed gpgme to /usr/local you should add
"/usr/local/lib" to your /etc/ and run ldconfig.

To diagnose the problem you may run "ldd gpa | grep libgpgme".

This will be a symlink.  If you follow that symlink (on a Linux machine)
it should show or

> gpg-agent runs, all certificates are recognized (where did all those
> expired ones come from???), and all error messages are gone.

I can't tell you - are these X.509 certificates?

> I vote beta783 version is ready for production!!

Unfortunately I am still aware of  a couple of bugs. Despite that I am
using 2.1 for years.



Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

More information about the Gnupg-users mailing list