moving up from 2.0.26 to 2.1.1

Philip Jackson philip.jackson at
Mon Feb 16 22:14:07 CET 2015

I passed an interesting Sunday afternoon : removed gnupg2.0.26 and attempted to
replace it with gnupg-2.1.2.  The experience was not entirely successful.

I got the updated libraries installed using configure/make/checkinstall.  I used
checkinstall because various howto articles on ubuntu's wiki recommend it and
deprecate the older 'make install'.

Checkinstall offered the advantage (or so it seemed to me) of producing a deb
package which when installed could be easily identified by the package
management system - all the easier to remove it later if needed.  Sure enough,
for the libraries involved, Synaptic Package Manager recognizes these packages
installed in the /usr/local/... region of the file system.

However, when it came to using checkinstall on the gnupg-2.1.2 build, the deb
package installed itself OVER the distro's gnupg-1.4.16. So the end result was a
gain of 2.1.2 together with a loss of 1.4.16.

Eventually, after re-installing 1.4.16 for a third time, and going back to 'make
install', I got 2.1.2 installed without losing 1.4.16.

2.1.2 started up and looked good until I tried to do something with it and then
it could not get gpg-agent running :

gpg-agent: "error while loading shared libraries: cannot open
shared object file: No such file or directory" is certainly present in /usr/local/lib/.

Then I ran out of time - put the distro standard version back into service and
went back to life (until next time).


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20150216/c8f65d2f/attachment-0001.sig>

More information about the Gnupg-users mailing list