Problems with key available in v1.4.19 but not v2.1.5

Philip Neukom pneukom at
Fri Jul 17 21:48:10 CEST 2015

Hello all.

I'm having some problems with my key that was created a long time ago
(1994) but updated with new emails over the years.

I am stuck after searching for an answer so thought I'd ask for some
guidance from the list.  I have reviewed the Docs, Mini Guide and HowTos.

I apologize in advance for the rather lengthy email but I figured I
had to put as much info so you may see what I've tried.

I moved my keys pubring.gpg, secring.pgp and trustdb.gpg to a new Mac
over the past week.

I downloaded and installed MacGPG for the GUI. I only installed the GPG
Keychain, GPG Services and MacGPG.

When I opened the GPG Keychain, all the keys were on the screen for a
brief moment and then the list shrunk and many keys disappeared in
addition to my personal public and secret keys. ???

So panic set in and I restored my pubring and secring from backup and
deleted the install of MacGPG.  I thought maybe there was a problem
with MacGPG so best to go back to command line Gnupg.

I installed 2.1.5 from source and found none of my keys in the
pubring and secring. What???

So I downloaded and installed 1.4.19, restored the pubring and secring
from backup again and found my public and secret keys are now listed.
This time I generated a revoke just in case and to test the install.
1.4.19 works fine.

Now I re-ran 2.1.5 and tried to find my keys.  Again they've gone
missing. [# gpg2 --list-keys]  None of my keys (pub and sec) are
available in 2.1.5.

Re-running [gpg --list-keys] with 1.4.19 and my keys are still there.

Why would v1.4.19 show my pub and sec keys but v2.1.5 wouldn't?  I
presume this is something very basic but I'm stumped.  I thought v1.x
and v2.x keys were interoperable??

Thanks in advance for any guidance,

PS I'm on digest mode so would appreciate if you could cc me directly on
any reply.  Thanks.

More information about the Gnupg-users mailing list