Problems with key available in v1.4.19 but not v2.1.5

Juan Miguel Navarro Martínez juanmi.3000 at
Sat Jul 18 01:09:40 CEST 2015

Pre-2.1: Public keys are in pubring.gpg and secret keys are in secring.gpg
Post-2.1: Public keys are in pubring.kbx and secret keys are in the
directory private-keys-v1.d[1].

Normally they should transition the Pre-2.1 keyrings to 2.1.X the first
time you use it or at least use pubring.gpg.

But if you wanna force-transition the public keyring, as shown in the
information about GnuPG2.1[2], you should do this commands:

$ cd ~/.gnupg
$ gpg --export-ownertrust >otrust.lst
$ mv pubring.gpg publickeys
$ gpg2 --import-options import-local-sigs --import publickeys
$ gpg2 --import-ownertrust otrust.lst
$ mv publickeys pubring.gpg

Second one exports the trust database, then renames pubring.gpg to
publickeys, next two ones import the trust database to GnuPG 2.1 and the
public keys from the rename GnuPG pre-2.1 keyring. Last command renames
it back to pubring.gpg so that it can be used by GnuPG 1.x and 2.0.x

As for the secret keyring, I don't know but I suppose you can always do:

$ gpg --export-secret-keys | gpg2 --import

As you have 1.4.19 and 2.1.5, `gpg` would be used for GnuPG 1.4.19 and
`gpg2` for GnuPG 2.1.5.

After you have done that, any change in either GnuPG pre-2.1 or post-2.1
keyrings won't be update into the other.


On 2015/07/17 at 21:48, Philip Neukom wrote:
> Hello all.
> I'm having some problems with my key that was created a long time ago
> (1994) but updated with new emails over the years.
> I am stuck after searching for an answer so thought I'd ask for some
> guidance from the list.  I have reviewed the Docs, Mini Guide and HowTos.
> I apologize in advance for the rather lengthy email but I figured I
> had to put as much info so you may see what I've tried.
> I moved my keys pubring.gpg, secring.pgp and trustdb.gpg to a new Mac
> over the past week.
> I downloaded and installed MacGPG for the GUI. I only installed the GPG
> Keychain, GPG Services and MacGPG.
> When I opened the GPG Keychain, all the keys were on the screen for a
> brief moment and then the list shrunk and many keys disappeared in
> addition to my personal public and secret keys. ???
> So panic set in and I restored my pubring and secring from backup and
> deleted the install of MacGPG.  I thought maybe there was a problem
> with MacGPG so best to go back to command line Gnupg.
> I installed 2.1.5 from source and found none of my keys in the
> pubring and secring. What???
> So I downloaded and installed 1.4.19, restored the pubring and secring
> from backup again and found my public and secret keys are now listed.
> This time I generated a revoke just in case and to test the install.
> 1.4.19 works fine.
> Now I re-ran 2.1.5 and tried to find my keys.  Again they've gone
> missing. [# gpg2 --list-keys]  None of my keys (pub and sec) are
> available in 2.1.5.
> Re-running [gpg --list-keys] with 1.4.19 and my keys are still there.
> Why would v1.4.19 show my pub and sec keys but v2.1.5 wouldn't?  I
> presume this is something very basic but I'm stumped.  I thought v1.x
> and v2.x keys were interoperable??
> Thanks in advance for any guidance,
> Philip.
> PS I'm on digest mode so would appreciate if you could cc me directly on
> any reply.  Thanks.
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

Juan Miguel Navarro Martínez

GPG Keyfingerprint:
5A91 90D4 CF27 9D52 D62A
BC58 88E2 947F 9BC6 B3CF

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20150718/78b8cf63/attachment.sig>

More information about the Gnupg-users mailing list