What am I doing wrong?

Mark Walter mwalter at paragon-csi.com
Wed Mar 18 13:59:11 CET 2015

No, Only the Private keys show up. What I tried to create and test was a public key to give to a partner for encrypting files sent to us.


Mark Walter

Business to Business Data Integration Specialist
Certified IBM System i Specialist
Paragon Consulting Services, Inc.
mwalter at paragon-csi.com
717-764-7909 ext. 20

-----Original Message-----
From: Daniel Kahn Gillmor [mailto:dkg at fifthhorseman.net] 
Sent: Wednesday, March 18, 2015 8:38 AM
To: Mark Walter; gnupg-users at gnupg.org
Subject: Re: What am I doing wrong?

On Wed 2015-03-18 08:18:11 -0400, Mark Walter wrote:

> I'm having issues with encrypt and decrypt and I know it's something 
> I'm doing wrong. I created a key with Kelopatra. Imported it into GNU 
> Privacy Assistant. It shows up as Fully Valid.
> Next, to test, I created the text file test.txt and used the following command to encrypt it.
> gpg -e -u myuser at domain.net -r myuser at domain.net test.txt

the -u myuser at domain.net is not doing anything here, because this is doing encryption and not signing.  so no secret key material is used in this step.

> The file test.txt.gpg showed up in my folder.
> Next, I tried to decrypt it using the following syntax.
> gpg -d test.txt.gpg
> And I get the following error.
> Gpg decryption failed: No secret key
> Not sure what I'm doing wrong here. This used to not be an issue.

It sounds to me like you imported your public key but not your secret key.

Does your key show up in the output of "gpg --list-secret-keys"  ?


No virus found in this message.
Checked by AVG - www.avg.com
Version: 2015.0.5751 / Virus Database: 4306/9322 - Release Date: 03/17/15

More information about the Gnupg-users mailing list