gpg-agent scdaemon + yubikey smartcard on Windows not asking for PIN with PUTTY

Bowlers Bloody bloodybowlers at
Wed Mar 23 14:33:29 CET 2016


I'm using my yubikey 4 as a smartcard to log on remote SSH with PUTTY,
under Windows.
Putty have a little software called pageant that keep your keys
available for putty to use. Unfortunately, it is not smartcard
Fortunately, it works if I use a modified pageant.exe found here :

Now, back to my problem : I read that recent version of
gpg4win/gpg-agent are compatible with putty and can replace pageant to
talk to putty. So I tried but the problem is, when I use gpg-agent, it
does not ask for a PIN (no PIN entry window) and then it fails in

This guy seems to have the same kind of problem :

I'm using Windows 7 64 bits with GnuPG 2.0.29 and Gpg4win 2.3.0. Using
putty 0.67.

I ran scdaemon and gpg-agent with logging in "guru" mode, and I can
post the results here if it helps.
It appears the card is read correctly, putty query is detected by
gpg-agent, only the PIN entry is not asked/triggered...

Any help appreciated, thank you

More information about the Gnupg-users mailing list