Having issues with dirmngr in gpg 2.1

Daniel Ranft Daniel.Ranft at giepa.de
Fri May 13 11:38:28 CEST 2016


Since a few weeks I cannot search keys anymore. When I use gpg --keyserver <something> --search-keys <somebody>, the commandline freezes and the process explorer does not show me a dirmngr.exe instance.
I then tried to investigate this further by trying to start the dirmngr manually with following result:

C:\Program Files (x86)\GNU\GnuPG\2.1.12\bin>dirmngr.exe --daemon
dirmngr[5020]: Error while opening `C:\ProgramData\GNU\etc\gnupg\ldapservers.conf': No such file or directory
dirmngr[5020]: The socket cannot be bound to `C:\Windows\S.dirmngr': Unknown error

I localized some parts of the string by myself as they were german.

What worked for me was to start the dirmngr manually with explicit --homedir %appdata%\gnupg, but I do not use an alternative homedirectory by environment variable or registry key. Therefore I think, gpg should try to create the socket file under %appdata%\gnupg instead of under C:\Windows.

Any suggestions where I should look for a mistake in my configuration?

Best regards,

More information about the Gnupg-users mailing list