gpg2 --version gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.3)
davidadamson.md at gmail.com
Sat Nov 19 00:24:41 CET 2016
I'm running a debian Jessie v8 kernel release 3.16.0-4-amd64 on my
personal laptop. It came pre-installed with GnuPG 1.4.18.
Rightly or not I thought having the latest version was a good idea for
no other reason than wanting to have the latest and greatest. So from
gnupg.org download page I downloaded and installed Gnupg Modern 2.1.15
along with the required libraries: nPth v1.2, Libgpg-error v1.25,
Libgcrypt v1.7.3, Libksba v1.3.5 and Libassuan v2.4.3. Integrity
checked them all.
After installation completed I ran gpg --version from the command line
and was presented with:
gpg (GnuPG) 1.4.18
but then saw reference online somewhere to gpg2 and figured that I
should be checking the version to that and so I ran gpg2 --version and
was presented with:
gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.3).
I would like to have either version at this point that works. I don't
like the idea of having misconfigured or improperly installed software
trashing up my system. If you can help me clean up my system and have
either version operational, I'd appreciate it.
I intend to use Gnupg just to encrypt and sign text and files.
Thanks in advance!
More information about the Gnupg-users