help with gnupg

Bereshka Web and Photo info at
Wed Aug 16 23:22:06 CEST 2017

Hello, Dear Creators :) 

I will very appreciate if you can help me, because I was surfing a lot in the internet looking for an answer, and read tones of forums, but did not find solution.

So I installed gnupg 2 , command gpg didn’t work in Terminal. I was confused and decided to try Gnupg tools suite, I installed that and created my keys and passphrase. Later I knew that I should type gpg2 in Terminal to work with that. So I got encrypted message and I tried to decrypt it, but it just didn’t show a result, it said that by whom it was encrypted and to whom, that’s all. We decided that it might be a problem because go GPG tools suite, maybe it causes conflict. So I decided to deinstall GPG Tools. Before to do that I exported my public, private, rev certificate, then I deinstalled this software. I located all keys to a folder “keys” at my user root folder). Then I imported all keys through terminal. To check I do —list-keys and I see my imported key and my husband’s key that was imported as well. 

1. The problem is that I can encrypt message and send it to him and that he can decrypt it. But when I get encrypted message from him I can’t decrypt it. It does’t ask my passphrase. It asked when I had GPG Tools, but even with asked passpharase with GPG Tools being installed i didn’t get a decrypted message
Now I don’t have GPG Tools and when I do command gpg2 Enter and insert his message I get this 

gpg: public key decryption failed: No pinentry
gpg: decryption failed: No secret key

2. Then, I decided that if there is so much mess with this email, I will create keys with other one (ytsan86 at , but I still get same error on the step of creation

gpg: public key decryption failed: No pinentry
gpg: decryption failed: No secret key

3. Also I found on one forum that file gpg-agent.conf should be edited with adding this line - pinentry-program /bereshka/bin/pinentry-qt
but it didn’t help

Below I pasted a piece of the process from my terminal. 

Last login: Tue Aug 15 20:37:38 on ttys000
Air-Anastasia:~ bereshka$ gpg2
gpg: WARNING: no command supplied.  Trying to guess what you mean ...
gpg: Go ahead and type your message ...























-----END PGP MESSAGE-----gpg: encrypted with 4096-bit RSA key, ID 2847B632DB4C2CD7, created 2017-08-13
      "Anastasiia Gudkov <info at>"
gpg: public key decryption failed: No pinentry
gpg: decryption failed: No secret key
gpg: signal Interrupt caught ... exiting

Air-Anastasia:~ bereshka$ gpg2 --list-keys
pub   rsa4096 2017-08-13 [SC] [expires: 2021-08-13]
uid           [ unknown] Anastasiia Gudkov <info at>
sub   rsa4096 2017-08-13 [E] [expires: 2021-08-13]

pub   rsa2048 2017-08-03 [SC] [expires: 2022-08-03]
uid           [ unknown] Dmitry Gudkov <bereska at>
sub   rsa2048 2017-08-03 [E] [expires: 2022-08-03]

Air-Anastasia:~ bereshka$ gpg2 --gen-key
gpg (GnuPG) 2.1.22; Copyright (C) 2017 Free Software Foundation, Inc.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Note: Use "gpg --full-generate-key" for a full featured key generation dialog.

GnuPG needs to construct a user ID to identify your key.

Real name: Anastasia Gudkov
Email address: ytsan86 at
You selected this USER-ID:
    "Anastasia Gudkov <ytsan86 at>"

Change (N)ame, (E)mail, or (O)kay/(Q)uit? o
We need to generate a lot of random bytes. It is a good idea to perform
some other action (type on the keyboard, move the mouse, utilize the
disks) during the prime generation; this gives the random number
generator a better chance to gain enough entropy.
gpg: agent_genkey failed: No pinentry
Key generation failed: No pinentry
Air-Anastasia:~ bereshka$ 

Best regards, 
Anastasiia Gudkov

-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20170816/1999b109/attachment-0001.html>

More information about the Gnupg-users mailing list