I'm confused about GPG, and it's confused about me

Reid Vail rsv869 at runbox.com
Tue Jan 17 21:09:16 CET 2017

Hello GPG team -

I have tried to get GPG working but am stuck and need some help isolating the
issue, please.

I'm running GnuPG 1.4.20-1 on Linuxmint KDE 18.  My mail package is
Claws-mail 1.13.2, but I don't think it's a mail issue.

I can run GnuPG at the command line and  can create a new key pair, and the output
from the --fingerprint option is shown directly below, but encrypting through Claws
fails with a error that simply says "encryption failed".

Next I tried to get a basic signature to work, and that fails also, shown next.  

I'm not sure how to troubleshoot my issue.  Pointers welcome.


rsv2 at rsv2-Serval-Pro ~ $ gpg --fingerprint rsv869 at runbox.com
pub   2048R/26F66FEB 2016-11-09
      Key fingerprint = 3A74 A1DB 2C79 6657 D14B  A6B8 3EDE 6A32 26F6 6FEB
uid                  Reid Vail <rsv869 at runbox.com>
sub   2048R/14C2E935 2016-11-09

pub   2048R/A780EFF6 2017-01-17
      Key fingerprint = 1F35 6DC3 3182 016A 8E59  E509 9A72 F153 A780 EFF6
uid                  Reid Vail (runbox) <rsv869 at runbox.com>
sub   2048R/1ED8FE07 2017-01-17


rsv2 at rsv2-Serval-Pro ~ $ 
rsv2 at rsv2-Serval-Pro ~ $ 
rsv2 at rsv2-Serval-Pro ~ $ gpg --clearsign --local-user --default-key encryption\ test
gpg: skipped "--default-key": secret key not available
gpg: encryption test: clearsign failed: secret key not available
rsv2 at rsv2-Serval-Pro ~ $ 

More information about the Gnupg-users mailing list