pinentry problems

Paul H. Hentze paul.hentze at
Tue Apr 17 00:04:11 CEST 2018

Hey folks,

I'm kinda stuck here with a problem with pinentry and could use some help.
I described the hole problem in detail here:

For all who don't like links, I will copy it down below.
Patrick Brunschwig already asked some questions and I tried some more
stuff, which is all documented under the link above, but nothing helped.

Has anybody any idea what to do?

Best wishes


- - - - - - - - - - - - - - -

Hi folks,

I'm having some problems with GPG right know and hope you can help me.
Debian 9, Thunderbird 52.7.0 (64-bit), Enigmail 2.0.2, GnuPG 2.1.18

I had a harddrive crash recently and had to set up the whole system from
scratch. Because I couldn't do it properly I saved the .gnupg folder und
now copied the whole thing to my new system at the same place. Since
then, I can't use Mailencryption.
I started with the faq page:
Under 'How to analyze' I tried debugging and get
> parseErrorOutputWith: status message:
> gpg: WARNING: unsafe permissions on homedir '/home/giraffenhorde/.gnupg'

So I fixed that with

> chown -R "$USER:$(id -gn)" ~/.gnupg
> chmod 700 ~/.gnupg
> chmod 600 ~/.gnupg/*

from here:

Now my secret keys are all gone.
gpg --list-secret-keys gives no output and in enigmail this doesn't work
When I want to put them in enigmail again, the system can't see them.

I tried gpg --gen-key and got even more

>  gpg: agent_genkey failed: Kein Pinentry
> Key generation failed: Kein Pinentry

I went back to the enigmail Troubleshooting advises above under 'How to
fix it' and tried further, so

1. is good
2. is good, I made this symlink thing, didn't help
3. is good, in my case it's
pinentry-program /usr/bin/pinentry-qt4
4. is good, the gnupg versions are matching
5. I don't need this one, because 4 was good they say
6. here is where I get
ERR 67108949 Kein Pinentry <GPG Agent>
7. when I type in
killall gpg-agent
 gpg-agent --debug-level expert --use-standard-socket --daemon /bin/sh
I get

> gpg-agent --debug-level expert --use-standard-socket --daemon /bin/sh
> gpg-agent[9469]: WARNING: "--use-standard-socket" is an obsolete
option - it has no effect
> gpg-agent[9469]: enabled debug flags: cache ipc
> gpg-agent[9469]: DBG: chan_4 <- OK Pleased to meet you, process 9469
> gpg-agent[9469]: DBG: chan_4 -> BYE
> gpg-agent: a gpg-agent is already running - not starting a new one
> gpg-agent: secmem usage: 0/65536 bytes in 0 blocks

I tried it without all unnecessary code above:
gpg-agent --debug-level expert /bin/sh
and I get

> gpg-agent[9477]: enabled debug flags: cache ipc
> gpg-agent[9477]: DBG: chan_3 <- OK Pleased to meet you, process 9477
> gpg-agent[9477]: gpg-agent running and available
> gpg-agent[9477]: DBG: chan_3 -> BYE
> gpg-agent[9477]: secmem usage: 0/65536 bytes in 0 blocks

So this debugging doesn't work somehow and there is no other terminal
window which opens as they say.

Have you got any idea what to do?
I could really use some help. Thanks in advance.

More information about the Gnupg-users mailing list