problems with pinentry

Paul H. Hentze paul.hentze at
Sun Apr 22 18:41:33 CEST 2018

Hey folks,

Debian 9, Thunderbird 52.7.0 (64-bit), Enigmail 2.0.2, GnuPG 2.1.18

I have a pinentry problem with GPG.
I tried to debug that, but it didn't work out.

I followed the 'How to fix it' advises, from enigmail:

1. is good
2. is good, I made this symlink thing, didn't help
3. is good, I'm using
pinentry-program /usr/local/bin/pinentry-qt
4. is good, the gnupg versions are matching
5. is good, already in there
6. here is where I get
> ERR 67108949 Kein Pinentry <GPG Agent="">
7. I tried this and get that some of the code is not necessary, so in
short, it is
gpg-agent --debug-level expert /bin/sh

> gpg-agent[9477]: enabled debug flags: cache ipc
> gpg-agent[9477]: DBG: chan_3 <- OK Pleased to meet you, process 9477
> gpg-agent[9477]: gpg-agent running and available
> gpg-agent[9477]: DBG: chan_3 -> BYE
> gpg-agent[9477]: secmem usage: 0/65536 bytes in 0 blocks

equally I can't use
gpg --gen-key

the return is
> gpg: agent_genkey failed: Kein Pinentry
> Key generation failed: Kein Pinentry

I attached the log-data from enigmail, where I reproduced the problem.
Maybe you can find something in there I didn't.

Has somebody any idea what to do?

Best wishes

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: logdata_enigmail
URL: <>

More information about the Gnupg-users mailing list