gpg: decryption failed: No secret key

Yu 999iscool at
Tue Aug 7 22:27:44 CEST 2018


I setup my gpg and keyed to Yubikey. My SSH works flawlessly. I have the
master key and subkeys. So my authentication key, encryption key, and
signing key should be totally fine.

John-Wong:tmp jwong$ gpg --list-secret-keys
sec#  rsa4096/0xC9E7221DAFCE6539 2018-08-07 [SC]
      Key fingerprint = 463F FBF9 0399 725F 240E  7A11 C9E7 221D AFCE 6539
uid                   [ultimate] John Wong <email>
ssb#  rsa4096/0xF7254D474BF6AD14 2018-08-07 [S]
ssb#  rsa4096/0xBAB7FE8D803C2351 2018-08-07 [E]
ssb>  rsa4096/0x676CA8641A239FE2 2018-08-07 [SA]

I am confused why I get this message:

    gpg: decryption failed: No secret key

I tried gpg --import but still doesn't help.

John-Wong:~ jwong$ gpg --import mastersub.key
gpg: key 0xC9E7221DAFCE6539: "John Wong <email>" not changed
gpg: To migrate 'secring.gpg', with each smartcard, run: gpg --card-status
gpg: key 0xC9E7221DAFCE6539: secret key imported
gpg: Total number processed: 1
gpg:              unchanged: 1
gpg:       secret keys read:

Does anyone have any ideas for why this is happening? Thank you very much.
This has been bothering me for few days now.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Gnupg-users mailing list