How do I delete secret subkeys correctly?

Matheus Afonso Martins Moreira matheus.a.m.moreira at
Thu Apr 11 16:06:22 CEST 2019

The --edit-key command did work this time. That's weird.
I tried this with my original keys and my experience matches
what Peter described. When I tried to delkey my original subkeys,
gpg deleted the public key packets, leaving the secret keys intact.

Public key list confirmed deletion of the subkeys from my public key
but the secret key list still included all my revoked subkeys.
The public key packets were promptly redownloaded and reintegrated
into the keyring when I searched for my user ID.

I don't understand why --edit-keys would work now,
or why --delete-secret-keys doesn't work as I expected.
Is it because I haven't sent my test keys to the keyservers?

The manual says delkey only deletes the public part of the key:

> delkey
> Remove a subkey (secondary key)
> Also note that this only deletes the public part of a key.

Even though it was able to delete the secret subkeys.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Gnupg-users mailing list