Restoring keyring from backup fails

Mike Grunweg grunweg at
Mon Apr 20 22:18:14 CEST 2020

Dear list,

I'm trying to restore my full gpg keyring from a backup of my .gnupg
folder, but no method I have tried seems to work.

What I tried:
Create a backup of the entire .gnupg folder on the old system.
On the new system, gpg was already installed. Replace the content of the
.gnupg folder with my backup.
(Both the backed-up and the new system have the same operating system,
with the same username, so the path layout should be identical.)

Expected result:
gpg recognises these files as my keyring, and I can use these keys just

Actual result:
Typing |gpg --list-keys| or similar lists nothing. Applications using
the keyring list no keys.

After that, I deleted the whole content of the .gnupg folder, and copied
only the files pubring.gpg, secring.gpg, and trustdb.gpg. The result
didn't change.

Any ideas what might be the cause, or how I can find out what's wrong?

One idea I had is that the new system has an encrypted hard disc (using
lux), but I feel that shouldn't matter.

Thanks for the help.

System information:
Debian GNU/Linux buster; the output of |gpg --version| begins with
gpg (GnuPG) 2.2.12
libgcrypt 1.8.4.

More information about the Gnupg-users mailing list