Migrating password store to new hard drive

Neil Webster jarraneil at gmail.com
Sun Apr 4 20:14:56 CEST 2021


I have recently installed a new SSD on my computer and I am trying to 
move my password store (using pass) to the new drive. I am using Ubuntu 
20.04.2 LTS.

I can see the individual *.gpg files that form the password store but I 
am not able to decrypt them.

Here are some things I have tried

$gpg -K

returns with nothing

Running gpg directly on a single file in the password store using

$gpg -d filename


$gpg: encrypted with 3072-bit RSA key, ID 94FDE31D5B3E9BC6, created 
"my at emailaddress.com"
$gpg: decryption failed: No secret key

I tried exporting the secret key from the old drive using

$gpg --export-secret-keys --armor --output privkey.asc my at emailaddress.com

and tried importing on the new drive using

$gpg --import privkey.asc

the import process seems to succeed with the following message
$gpg: key D96B626F551DE067: "my at emailaddress.com" not changed
$gpg: key D96B626F551DE067: secret key imported
$gpg: Total number processed: 1
$gpg:              unchanged: 1
$gpg:       secret keys read: 1
$gpg:  secret keys unchanged: 1

Not sure if it is important or not but inside the 
~/.gnupg/private-keys-v1.d/ directory I have 2 files


Cheers, Neil

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.gnupg.org/pipermail/gnupg-users/attachments/20210404/7cc29e1e/attachment-0001.html>

More information about the Gnupg-users mailing list