Decryption w/o public key does not work in GnuPG 2.3.2

Werner Koch wk at
Thu Aug 26 11:00:10 CEST 2021


On Wed, 25 Aug 2021 21:36, Thomas Cage said:

> I have installed the new 2.3.2 version which supports "decryption w/o
> public key but with correct card inserted" with commit 50293ec2eb.

The description is a bit too brief.  What we do is to lookup the key on
a configured LDAP server.  This allows to start using a new box
immediately by simply inserting your smartcard.  It is a feature for
largers deployments.

> I have tried it out with a couple files encrypted with a public key
> that got lost recently but the private key remains in my smart card. $

You need to get the public key or re-create it.  To do this you need to
know the creation time.  This can be done by looping over a range of
dates - unfortunately tehre is still no tool to do this.

> Am I using this feature in the correct way? I just hope my files won't
> get lost forever. Thanks a lot!

It is a matter ot the available tools or the time required to write them



Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 227 bytes
Desc: not available
URL: <>

More information about the Gnupg-users mailing list