gpgsm "Encrypt failed" "Unusable public key: 53A51054BB68F7C3" root certificate missing?

Uwe Brauer oub at
Sun Dec 26 09:20:24 CET 2021


I am on Ubuntu 16.04 running 

gpgsm (GnuPG) 2.1.11
libgcrypt 1.6.5
libksba 1.3.3-unknown

I am also a die hard user of emacs and use it for encrypting and
decrypting my mails.

I received a smime message from a colleague (with his public key
embedded of course).

When I tried to send him a smime encrypted and signed message I obtained
the lisp error:

Debugger entered--Lisp error: (epg-error "Encrypt failed" "Unusable public key: 53A51054BB68F7C3")

I suspect that the key was signed from an authority whose root
certificate I don't posses.

For example using thunderbird and opening his signed message, I see

I also tried to run 
gpgsm -e -r arober at epg-bug.txt

But I receive 

gpgsm: enabled debug flags: ipc
gpgsm: can't encrypt to 'arober at': Ambiguous name
secmem usage: 0/16384 bytes in 0 blocks

I am not sure whether this connected, but I do have old certificates of
this user.

Any help would be strongly appreciated.


Uwe Brauer 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.png
Type: image/png
Size: 28207 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5673 bytes
Desc: not available
URL: <>

More information about the Gnupg-users mailing list