[SOLVED] (was: gpgsm "Encrypt failed" "Unusable public key: 53A51054BB68F7C3" root certificate missing?)

Uwe Brauer oub at mat.ucm.es
Mon Dec 27 17:34:36 CET 2021

>>> "UBvG" == Uwe Brauer via Gnupg-users <gnupg-users at gnupg.org> writes:

> Hi 

> I am on Ubuntu 16.04 running 

> gpgsm (GnuPG) 2.1.11
> libgcrypt 1.6.5
> libksba 1.3.3-unknown

> I am also a die hard user of emacs and use it for encrypting and
> decrypting my mails.

> I received a smime message from a colleague (with his public key
> embedded of course).

> When I tried to send him a smime encrypted and signed message I obtained
> the lisp error:

> Debugger entered--Lisp error: (epg-error "Encrypt failed" "Unusable public key: 53A51054BB68F7C3")

It turned out that I indeed needed root certificate 

That I imported via 

  gpgsm --import *.cer

Then everything was fine. Sorry for the noise.


Uwe Brauer 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5673 bytes
Desc: not available
URL: <https://lists.gnupg.org/pipermail/gnupg-users/attachments/20211227/b95785eb/attachment.bin>

More information about the Gnupg-users mailing list