Problems when importing previously exported private keys on new linux system.

Vladislav Alekseev Alekseevvladislav2hy at
Sun Aug 14 13:30:07 CEST 2022

Sorry for replying late, this is my first use with mailing list and I didn't notice your email.

Unfortunately, I forgot the gnupg version number on my old linux. But as I created cron tasks to have my system update daily, I think it's up to date with apt. I'll provide other assistance if you want me to.

I've talked the thing with Andrew Savchenko <andrew at>, but I didn't know I should CC to gnupg-users at to make my mails visible to all users.

If you want and permit me to, I will forward all my emails with Andrew here.

When I trying to recover my keys, I found something interesting. (I had shared it with Andrew)
I'm working on Windows these days, and I found something interesting.
I created a new key pair and then export private key both with "-a" parameter and without.
Then when I tried to re-import them, the same error occurred with both key files.
But, when I manually copy content in armored private key file and paste it after "gpg --import" command, it worked as expected.

To sum up, it seems that if I am restoring a key from file, it won't work.
If I copy from a armored file and then paste to shell, it will work as expected.
​I created a linux machine today and all the actions succeeded as expected. I also export my keys and download it to my windows (both armored and not), and succeeded to import, failed to export to file then re-import.

I'll post my keys, environment and version data here once I reach my Windows laptop.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Gnupg-users mailing list