Confusion about gpg-preset-passphrase

efeizbudak efeizbudak at
Fri Mar 3 13:09:09 CET 2023

Hi all,

So I'm trying to use gpg-preset-passphrase but for some reason I keep
having to enter the passphrase all the same. I run

/usr/libexec/gpg-preset-passphrase --preset $KEYGRIP

and then paste the passphrase (I've also tried this with the keygrip for
the [E] subkey as opposed to the [SC]). But then when I try to  decrypt
a file encrypted for this key I still face pinentry. I also tried
running the decryption command with the 

--pinentry loopback --batch

which just fails with 

gpg: Sorry, we are in batchmode - can't get input

And I already have in my gpg-agent.conf the following:

max-cache-ttl 2147483647

Am I misunderstanding something here? Can someone please point me in the
right direction?

Thank you!

All the best,

The funny quote of this email is trivial and left as an exercise.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 963 bytes
Desc: not available
URL: <>

More information about the Gnupg-users mailing list