Adding new uid to causes bad signature

Eva Bolten Eva.Bolten at
Fri May 3 14:44:09 CEST 2024


I have tried to replicate your issue using a Yubikey 5 NFC, doing what you 
> In general, I don't think my procedure for adding a new uid is abnormal:
> $ gpg --edit-key 408FB2EBC3DF3DBBE0143D9A29AD46D6F58287A3
> gpg> adduid
> gpg> save

For my key and using gpg 2.4.5 on a standard Windows 10 system "check" didn't 
give an error and signing a document worked without any issues.
I used a simple brainpool standard testkey with only one subkey, though.

> General info:
> OS: Windows 11 (AtlasOS) & MacOS 14.1.1 (tried on both)
> GPG: GPG 2.4.4.-unknown (bundled with git-scm windows installer), GPG
> 2.4.5 (homebrew)
> My public keys:
> Before trying to add a new uid:
> After trying to add a new uid:

Importing your second pubkey did not change anything noticeable, gpg reported 
no changes on the key and there is no new UID to be seen.
So it seems it was not exported. To avoid any confusion does 

  gpg -k 408FB2EBC3DF3DBBE0143D9A29AD46D6F58287A3

show the new UID for you?

Is there additional info if you add "--list-options show-unusable-uids" 
before the "-k"?



g10 Code GmbH           AmtsGer. Wuppertal HRB 14459
Bergstr. 3a                               Geschäftsführung Werner Koch
D-40699 Erkrath      USt-Id DE215605608

More information about the Gnupg-users mailing list