[gnutls-dev] API comment
Simon Josefsson
simon+gnutls-dev@josefsson.org
Sat Jan 19 21:00:01 2002
>From gnutls.h:
GNUTLS_BulkCipherAlgorithm gnutls_cipher_get_algo( GNUTLS_STATE
state); GNUTLS_KXAlgorithm gnutls_kx_get_algo(
GNUTLS_STATE state); GNUTLS_MACAlgorithm
gnutls_mac_get_algo( GNUTLS_STATE state); GNUTLS_CompressionMethod
gnutls_compression_get_algo( GNUTLS_STATE state);
IMHO abbrevations ("algo") are bad in the long run, but in this
case it might better to remove the "_algo" part alltogether (only
two of the four things are algorithms, the other are
'methods'). It also makes it consistent with the names of
gnutls-*-set-priority where "algorithm" isn't used.
(Maybe #define the old names to the new ones for a couple of major
releases.)