[gnutls-dev]configure fails (in Gentoo Linux)

Wes Morriston morristo at stripe.colorado.edu
Thu Aug 15 05:21:01 CEST 2002


I'm trying to compile gnutls-0.5.1, and it can't seem to work with the 
libgcrypt I have installed.  I have libgcrypt-1.1.8.  

    /usr/bin/libgcrypt-config --version



No other version of libgcrypt is installed.

And yet whenever I run configure, I get the error message you see below.

I have tried several different versions of libgcrypt and gnutls.  I run 
into the same problem with all of them.  I've also done this on another 
machine running Gentoo Linux.  Same exact thing.  (NOTE: I'm running the 
very latest version of Gentoo Linux.)

I attach a copy of the config.log file.

A fix would be most appreciated!  I want to get wmbiff running with ssl 
support, and it uses gnutls.


checking for libgcrypt-config... /usr/bin/libgcrypt-config
checking for libgcrypt - version >= 1.1.8... no
*** Could not run libgcrypt test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding LIBGCRYPT or finding the wrong
*** version of LIBGCRYPT. If it is not finding LIBGCRYPT, you'll need to 
set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location  Also, make sure you have run ldconfig if that
*** is required on your system
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error:
*** libgcrypt was not found. You may want to get it from
*** ftp://ftp.gnupg.org/pub/gcrypt/alpha/libgcrypt/

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: config.log
URL: </pipermail/attachments/20020815/450582c3/attachment.asc>

More information about the Gnutls-devel mailing list