[PATCH] add DN import function

Nikos Mavrogiannopoulos nmav at gnutls.org
Sat Feb 16 10:25:38 CET 2008

On Thursday 14 February 2008, Joe Orton wrote:
> The CA dnames passed to the client-cert-retrieve function are raw DER
> and hence can't be used by gnutls_x509_dn_get_rdn_ava().
> This patch adds gnutls_x509_dn_import() which fills that gap, and
> gnutls_x509_free_dn() which destroys the allocated structures.
> The naming is slightly awkward because these don't fit the usual
> init/import/deinit convention used by GnuTLS; let me know if you'd
> prefer different names.

This is a nice addition, thank you. About the nameing I think
gnutls_x509_free_dn should be better named gnutls_x509_dn_deinit to be more 
consistent with the other deinitialization functions. Would this be ok with 


More information about the Gnutls-devel mailing list