[gnutls-devel] gnutls 3.3.17

Marius Schamschula lists at schamschula.com
Mon Aug 10 17:39:50 CEST 2015


Two notes:

1) Installing autogen 5.18.4 made no difference

2) I see the identical error with gnutls 3.4.4

On Aug 10, 2015, at 9:11 AM, Nikos Mavrogiannopoulos <nmav at gnutls.org> wrote:

> On Mon, Aug 10, 2015 at 2:50 PM, Marius Schamschula
> <lists at schamschula.com> wrote:
>> Nikos,
>> I’m not sure what happened between gnutls 3.3.16 and 3.3.17 to cause the
>> following errors: (seen under OS X 10.10.4, Note: I am passing
>> --enable-local-libopts which is supposed to prevent this issue. Also tried
>> building w/o autoconf with same result)
>> In file included from In file included from srptool-args.c:43:
>> ./srptool-args.h:61:3: error: option template version mismatches
>> autoopts/options.h header
>> # error option template version mismatches autoopts/options.h header
> That's a libopts issue. When the auto-generated files from autogen are
> regenerated
> using a newer autogen, the included libopts library is automatically
> invalidated. The check
> in libopts is for any version (major, minor or even patch - as in that case).
> A work-around would be to regenerate the autogen files locally with
> autogen 5.18.4 to make --enable-local-libopts work.
> I'd have to add some check for autogen/included libopts match to
> prevent this from happening again.
> regards,
> Nikos

Marius Schamschula

More information about the Gnutls-devel mailing list