[gnutls-devel] GnuTLS | Deadlock in _gnutls_epoch_get on mutex epoch_lock with msmtp and gnutls 3.6.7 (#758)

Development of GNU's TLS library gnutls-devel at lists.gnutls.org
Tue Apr 14 02:41:32 CEST 2020

Alex commented:

seems to be related to nss-resolve somehow... valgrind reports that pthread_mutex_lock from _gnutls_epoch_get accesses uninitialized memory. strangely, it doesn't on Arch though. I've tried recompiling systemd, gnutls, and msmtp with conservative CFLAGS (-O2 -ggdb3) as well as identical CFLAGS/LDFLAGS to Arch, and it still only happens on Gentoo. also tried kernel.randomize_va_space=0, no difference on either.

Reply to this email directly or view it on GitLab: https://gitlab.com/gnutls/gnutls/-/issues/758#note_323006229
You're receiving this email because of your account on gitlab.com.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.gnupg.org/pipermail/gnutls-devel/attachments/20200414/ff5cbaed/attachment.html>

More information about the Gnutls-devel mailing list