[gnutls-devel] GnuTLS | Disable test scripts on windows (!1594)

Read-only notification of GnuTLS library development activities gnutls-devel at lists.gnutls.org
Thu May 19 17:02:13 CEST 2022

Alexander Sosedkin commented:

I've tried to dig down to the root cause for some limited time and failed.

I've also independently arrived at a conclusion that redirection plays a role here,
but I suspect that it's not just input redirection that's suddenly problematic
(e.g., tests/cert-tests/aki.sh also occasionally fails, but uses only output redirection).

I've tried eliminating redirection in favor of `--infile`/`--outfile` in `tests/rfc2253-escape-test.sh`
then just `--infile`,
and my current feeling is that input redirection fails reliably and output redirection fails probabilistically,
but I don't have the hard facts to back that speculation of mine.

`Application tried to create a window, but no driver could be loaded` etc. seems like a red herring to me.

Please also file an issue to fix and restore the disabled coverage.

Reply to this email directly or view it on GitLab: https://gitlab.com/gnutls/gnutls/-/merge_requests/1594#note_953090751
You're receiving this email because of your account on gitlab.com.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.gnupg.org/pipermail/gnutls-devel/attachments/20220519/a6ec290b/attachment.html>

More information about the Gnutls-devel mailing list