[Help-gnutls] gnutls-srpcrypt creates an empty tpasswd.

Nikos Mavroyanopoulos nmav at gnutls.org
Mon Jun 9 11:07:37 CEST 2003

On Mon, Jun 09, 2003 at 05:12:02PM +0900, Hiroshi Hayakawa wrote:

> Hi all,
> I just tried using gnutls-0.8.7 on RedHat 9.0.
> That has been compiled successfully with libtasn1-0.1.2,
> libgcrypt-1.1.12 and opencdk-0.4.5.
> After installing all stuffs under /usr/local as the default,
> I used gnutls-srpcrypt to generate tpasswd.conf and tpasswd.
> Here below are what I did:
> >gnutls-srpcrypt --create-conf ./tpasswd.conf
> >gnutls-srpcrypt --passwd ./tpasswd --passwd-conf ./tpasswd.conf -u test
> Enter passwd: (I entered a string here.)
> Segmentation fault
> This created an empty ./tpasswd and ./tpasswd.tmp.
> Then I tried it again.

Could you catch the segmentation fault with the debugger?
$ gdb gnutls-srpcrypt
() run --passwd ./tpasswd --passwd-conf ./tpasswd.conf -u test

and type "bt" to print a backtrace. This may provide some
information about the segmentation fault.

> Thanks,
> Hiro
> _______________________________________________
> Help-gnutls mailing list
> Help-gnutls at gnu.org
> http://mail.gnu.org/mailman/listinfo/help-gnutls

Nikos Mavroyanopoulos

More information about the Gnutls-help mailing list