[Help-gnutls] Client OpenPGP verification fails

Mario Lenz mario.lenz at gmx.net
Tue Jul 18 22:22:12 CEST 2006


I've been trying not only to verify the server, but also the client. I
have this problem with one of the daily 1.5.0 snapshots as well as with
the 1.4.1 version. To make sure it wasn't my mistake, I tried to use
gnutls-serv and gnutls-cli from src:

cd libgnutls-1.4.1/src
./gnutls-serv --echo --pgpkeyfile /path/to/privkey
--pgpcertfile /path/to/pubkey --dhparams params.pem

I found params.pem in the src directory.


Error in handshake
Error: A TLS packet with unexpected length was received.


cd libgnutls-1.4.1/src
./gnutls-cli --xml --pgpkeyfile /path/to/otherprivkey
--pgpcertfile /path/to/otherpubkey -p 5556 localhost

ends with:

*** Fatal error: GnuTLS internal error.
*** Handshake has failed
GNUTLS ERROR: GnuTLS internal error.

If I dont't tell the client to use keys to identify, everything works.
I've tried to find the error, but it's com- pli- ca- ted. If you want me
to run it again in debug mode and mail the output, please tell me what
level (-d ?) you would prefer.



gnutls_certificate_set_openpgp_key_mem doesn't work either, but the
problem seems to be in libopencdk. Does anyone know if this is a general
OpenCDK problem or one that's specific to Debian Etch?

More information about the Gnutls-help mailing list