[Help-gnutls] again ex-serv-pgp

dellanna at csp.it dellanna at csp.it
Tue Feb 13 11:51:59 CET 2007

excuse me, but the example "ex-serv-pgp" is correct?
I tried to install gnutls-cli 1.7.6 version in windows machine... this operation
was completed successfully.
1. I run ex-serv-pgp on ubuntu machine. The application work correctly because
it return :

 Echo Server ready. Listening to port '5556'.

2. When I run on windows machine (on the same LAN) gnutls-cli --port 5556

hostname_OF_Linux_Machine it return the following output:
Resolving "hostname"
Connecting to ''
***Fatal error: A TLS packet with unexpected length was received.
Handshake has failed
GNUTLS ERROR: A TLS packet with unexpected lenght was received.

3. On server side (Linux Machine with ex-serv-pgp running) the output is:

-connection from, port 2638
*** Handshake has failed (Could not negotiate a supported cipher suite.)

What is the problem? I think I blunder something with gnutls-cli (on client


This message was sent using IMP, the Internet Messaging Program.

More information about the Gnutls-help mailing list