[Help-gnutls] Re: some experience

Simon Josefsson simon at josefsson.org
Wed Feb 21 11:22:48 CET 2007

dellanna at csp.it writes:

> Hi,
> Scrive Simon Josefsson <simon at josefsson.org>:
>> Yes, the procedures are the same.  GnuTLS 1.6.x and 1.7.x are quite
>> similar, although for OpenPGP support, you'll want 1.7.x.
> 1.7.0 support OpenPGP?


> In this version if I run gnutls-cli --port 5556 test.gnutls.org it return:
> global_init_extra: The GnuTLS library version does not match the GnuTLS-extra
> library version.

This indicate there was a problem when GnuTLS was installed -- it is
using the wrong libgnutls-extra library.  That has to be solved first.

> Is correct this output?

Nope.  The server should send its OpenPGP server key instead of the
X.509 certificate, if you are using a correctly installed recent
GnuTLS version.

>> I think that either your gnutls archive was corrupt, or ./configure
>> failed to create the Makefile.  Did ./configure exit with an error
>> message?
> Yes, I resolved this problem for versions 1.6.0 and 1.7.0. But the problem
> remains for 1.7.5 version.
> There isn't error message.

Can you reproduce this with a clean build of GnuTLS 1.7.6?  It seems
for some reason, your different GnuTLS installations seems to confuse
each other.


More information about the Gnutls-help mailing list