[Help-gnutls] Problem starting gnutls-serv with PSK support

Sebastian Hans sebastian_hans at yahoo.com
Mon Jan 1 17:46:11 CET 2007


I have problems starting gnutls-serv with support for the PSK keyexchange. When I run the gnutls-cli-debug against the server the output shows that no protocol is supported.

To start the gnutls-serv I use the following command

gnutls-serv -d 10 -p 4433 --http --ciphers AES --protocols TLS1.1 --kx PSK --pskpasswd sha16.psk

the output generated by gnutls-cli-debug is:

C:\downloads\SSL-APIs\GnuTLS\bin>gnutls-cli-debug localhost -p 4433
Resolving 'localhost'...
Connecting to ''...
Checking for TLS 1.1 support... no
Checking fallback from TLS 1.1 to... failed
Checking for TLS 1.0 support... no
Checking for SSL 3.0 support... no

Server does not support none of SSL 3.0, TLS 1.0 and TLS 1.1

I tried a lot of variations but nothing worked.

I using now version 1.6.1 in Windows XP



Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20070101/f21cc6d5/attachment.htm>

More information about the Gnutls-help mailing list