Nathan Redden nredden at
Mon Jul 26 17:02:51 CEST 2010

Thank you for your quick response to this problem, but I do not know how to build the library in Windows. I am building a cross-platform library for Windows and Linux, (which is one of the reasons GnuTLS was chosen), and have started on the Windows side. I did not build the Windows libraries, I just downloaded and installed the pre-built binaries. 

I looked at the instructions on the download page, but I do not have a 'make' program installed with Visual Studio 2008 which I am currently using. I tried to substitute the 'nmake', but it did not work. Can you send me instructions on what compiler you are using and how to build under Windows? 

Thanks again,
Nathan Redden
-----Original Message-----
From: Nikos Mavrogiannopoulos [mailto:nmav at]
Sent: Monday, July 26, 2010 06:11 AM
To: 'Nathan Redden'
Cc: help-gnutls at
Subject: Re: TLS_RSA_NULL_MD5

On Mon, Jul 26, 2010 at 2:57 AM, Nathan Redden wrote: > > I have been implementing a TLS 1.2 implementation using the GnuTLS library. I have a requirement to be able to use no data encryption. The cipher suite > TLS_RSA_NULL_MD5 is listed in the supported cipher suites, but I cannot figure out how to force GnuTLS to only negotiate this. I have tried all of the Common keywords and > eliminated all ciphers and starting from NONE adding in the key exchange, compression, and MAC. I have tried compatibility mode as well. You must have been the first one using this ciphersuite. It never seemed to work. To get it apply the attached patch, and verify it using the priority string "NONE:+RSA:+MD5:+NULL:+VERS-TLS1.0:+COMP-NULL". regards, Nikos 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20100726/66d2457a/attachment.htm>

More information about the Gnutls-help mailing list