[2.8.6] build time symbol not found error.

dev.admin at ntlworld.com dev.admin at ntlworld.com
Mon May 31 01:27:25 CEST 2010


I feel a bit of a noob but I can't seem to get the
current or previous versions to build.

I did read the README and tried the suggested
flags but I still get the same problem.

I'm building it as a static.


output from make.
Making all in x509
libtool: link: gcc -std=gnu99 -arch x86_64 -g -Os -pipe -no-cpp- 
precomp -arch x86_64 -bind_at_load -o errcodes errcodes.o  ../ 
lib/.libs/libgnutls.a -L/usr/local/gnu/lib.a/lib /usr/local/gnu/lib.a/ 
lib/libtasn1.a -lz /usr/local/gnu/lib.a/lib/libgcrypt.a -L/usr/local/ 
gnu/lib/lib /usr/local/gnu/lib.a/lib/libgpg-error.a /usr/local/gnu/lib/ 
lib/libintl.dylib /usr/local/gnu/lib/lib/libiconv.dylib -lc ../ 
Undefined symbols:
   "__gnutls_log_func", referenced from:
       __gnutls_log in libgnutls.a(gnutls_errors.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[4]: *** [errcodes] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20100531/893892e5/attachment.htm>

More information about the Gnutls-help mailing list