GnuTLS and pkg-config

Jeffrey Walton noloader at
Sun Nov 21 04:49:09 CET 2010

On Sat, Nov 20, 2010 at 10:26 PM, Brad Hards <bradh at> wrote:
> On Sunday, November 21, 2010 01:53:42 pm Jeffrey Walton wrote:
>> $ pkg-config gnutls --cflags
> This is the right syntax (not the "[lib]gnutls26" thing you tried later).
OK. Thanks. When pkg-config did not work for the general name, I began
trying specific names.

> bradh at bradh-VirtualBox:~$ pkg-config gnutls --libs
> -lgnutls
> bradh at bradh-VirtualBox:~$ apt-cache pkgnames | grep libgnutls | sort
> libgnutls26
> libgnutls26-dbg
> libgnutls-dev
> on my ubuntu 10.10 box, using packages.
> Are you sure you've installed it correctly?
I believe so. I usually use the point-and-click Synaptic Package
Manager out of laziness. I reserve apt-cache and apt-get for problems.

> Have you tried looking for gnutls.pc on the filesystem?
It looks like lots of libraries are missing the PC files, including GnuTLS.

$ ls /usr/lib | wc
   1833    1833   33085
$ ls /usr/lib/pkgconfig/ | wc
     58      58     913

> Does it work for other packages?
Going out on a limb, I'm guessing about 58 of 1800 or so will work.

> In any case, it works from source, so this is an issue between you and your
> distro packages (rather than a gnutls issue).
Agreed. I'll get a report in for the missing package configuration file.

Thanks for the help,

More information about the Gnutls-help mailing list