LDAP over SSL does not work with Ubuntu Prolonged Pain

Thorsten Glaser t.glaser at tarent.de
Tue May 22 19:07:39 CEST 2012

On Tue, 22 May 2012, Nikos Mavrogiannopoulos wrote:

> Let's get the facts straight. What have you actually tried?

I’ve tried to connect to the server using OpenSSL and GnuTLS.
Both were pointed to a CA bundle containing the server CA.
With OpenSSL, the connection succeeds, and it says it can
validate the server certificate. With GnuTLS on older *buntu
systems and current Debian, the connection similarily succeeds.
With GnuTLS on the last two *buntu releases, it fails. I’ve
looked up in slapd.conf which certificates it uses, tarred
them up and sent them.

I’m not familiar with gnutls-cli and other non-OpenSSL tools,
so if I should test other things, please tell me what and how.

tarent solutions GmbH
Rochusstraße 2-4, D-53123 Bonn • http://www.tarent.de/
Tel: +49 228 54881-393 • Fax: +49 228 54881-314
HRB AG Bonn 5168 • USt-ID (VAT): DE122264941
Geschäftsführer: Boris Esser, Elmar Geese

More information about the Gnutls-help mailing list