[gnutls-help] Compiling gnutls on solaris

Mat Troi mattroisang at gmail.com
Fri Sep 26 01:42:02 CEST 2014

I am working on compiling it for Solaris 11 on x86 Intel platform, not
Sparc.  Has anyone gotten it to work that way for Solaris 10?  So far, I
was able to compiled libnettle and libgmp, and got the gnutls ./configure
to run, but when I tried to run make, I ran into this issue with libtool:
../libtool[1100]: eval: syntax error at line 1: `|' unexpected *** Error
code 3

More info is here:

I modified libtool manually and now I am at:

ld: warning: symbol referencing errors
Text relocation remains                         referenced
    against symbol                  offset      in file
_gnutls_x86_cpuid_s                 0x3a
ld: fatal: relocations remain against allocatable but non-writable sections
collect2: error: ld returned 1 exit status
*** Error code 1
The following command caused the error:

On Thu, Sep 25, 2014 at 9:58 AM, Nikos Mavrogiannopoulos <nmav at gnutls.org>

> On Thu, 2014-09-25 at 10:05 -0400, dev wrote:
> > may as well reply to myself as I see the problem and please pardon me
> > for unrolling the conditional expression in ./lib/x509/verify-high2.c
> > for the function load_dir_certs() :
> [...]
> > That is borked.
> >
> > The use of d_type from dirent.h is not portable
> > as it is a GNUism from linux land only.
> >
> > No such animal exists in the POSIX dirent.h :
> > http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/dirent.h.html
> Correct. I've committed a fix. It is usually simpler and faster to
> propose a patch for such issues.
> regards,
> Nikos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20140925/6c967d93/attachment.html>

More information about the Gnutls-help mailing list