[gnutls-help] install gnutls failed on MacOSX 10.11.5 (El Capitan)

Rudi van Houten rudi at droho.nl
Thu Jul 7 23:29:08 CEST 2016

I try to install gnutls, needed for wget.
GnuTLS needs libgmp (no problem) and libnettle, and that seems
a problem.
I installed the youngest libnettle that I found (3.2) but the gnutls
configure scripts complains about not finding nettle-3.1.

I also tried with nettle versions 3.0 and 3.1, SAME RESULT, NO SUCCESS.

The 'make install' in nettle babbles about libnettle.6

What can I do to get gnutls correctly compiled and installed?

thanks for advice, I retired 10 years ago as unix system administrator and
thought this should be a routine job. But no ....... HELP!!

tail from make install in libnettle-3.2:
echo timestamp > stamp-h
./install-sh -c -d /usr/local/lib
for f in libnettle.a ; do \
          /usr/bin/install -c -m 644 $f /usr/local/lib ; \
./install-sh -c -d /usr/local/lib/pkgconfig
for f in nettle.pc  ; do \
          /usr/bin/install -c -m 644 "$f" /usr/local/lib/pkgconfig ; \
./install-sh -c -d /usr/local/lib
/usr/bin/install -c -m 644 libnettle.dylib /usr/local/lib/libnettle.6.2.dylib
[ -z "libnettle.6.dylib" ] \
                || (cd /usr/local/lib \
                && rm -f libnettle.6.dylib libnettle.dylib \
                && ln -s libnettle.6.2.dylib libnettle.6.dylib \
                && ln -s libnettle.6.2.dylib libnettle.dylib)
set -e; for d in tools testsuite examples; do \
          echo "Making install in $d" ; (cd $d && /Applications/Xcode.app/Contents/Developer/usr/bin/make install); done
Making install in tools
.././install-sh -c -d /usr/local/bin
for f in sexp-conv nettle-hash nettle-pbkdf2 nettle-lfib-stream  ; do \
          /usr/bin/install -c $f /usr/local/bin ; \
Making install in testsuite
Making install in examples
houten at goudreinet (738)>

tail from ./configure in gnutls-3.5.2
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for bison... bison -y
checking for a sed that does not truncate output... /usr/bin/sed
checking whether to build with code coverage support... no
checking for autogen... :
configure: WARNING:
*** autogen not found. Will not link against libopts.
checking for inline... inline
checking for ANSI C header files... (cached) yes
checking cpuid.h usability... yes
checking cpuid.h presence... yes
checking for cpuid.h... yes
checking for getrandom... no
checking for getentropy... no
checking for NETTLE... no
configure: error:
  *** Libnettle 3.1 was not found.

houten at goudreinet (746)>

Rudi van Houten -- Netherlands
:-) Fantasy is given mankind to make amends for what he is not,
    and a sense of humour as consolation for what he is.

More information about the Gnutls-help mailing list