gcrypt.m4 and libgcrypt-config mismatched

Neil Spring nspring at cs.washington.edu
Sat Nov 29 12:35:09 CET 2003

I tried today to install libgcrypt-1.1.44 in /usr/local on
my debian machine, but when I build software that requires 
it, it complains.   I tried to force that software to find
the /usr/local installed newer version using:

./configure --with-libgcrypt-prefix=/usr/local

(the autoconf fragment uses AM_PATH_LIBGCRYPT(1.1.42...))

Using strace, I discovered that it calls: 

/usr/local/bin/libgcrypt-config --prefix=/usr/local --version

which barfs with a usage statement, while my
/usr/bin/libgcrypt-config seems content to gobble --prefix
and print the version number.

diff found no differences between my system's libgcrypt.m4 and
the libgcrypt.m4 in libgnutls-1.1.44.

I expect the problem is line 23 of libgcrypt.m4:
 libgcrypt_config_args="$libgcrypt_config_args --prefix=$libgcrypt_config_prefix"

Or, alternately, that a --prefix=*) case should be added to
libgcrypt-config, though I don't know what it would do.


More information about the Gcrypt-devel mailing list