Status Update: HW Mysteriously Stopped Working. Development Suspended.

tomli at tomli at
Sat Feb 10 19:27:17 CET 2018


I've received 5 pieces of GD32F103 for testing yesterday!

However, I tried to program the new board with a ST-Link-v2-compatible clone,
but it didn't work. Then I tried to program a knownly-working FST-01 board,
but found it still refused to work, despite the fact that the board was just
programmed by this programmer one day ago and working as a Gnuk token on the
computer. OpenOCD kept showing the wrong (low) target voltage.

I thought it was a wiring program, and tried to hook up the wires again, and
suddenly, the magic smoke came out from STM32F103 chip, unbelievable, the power
supply never exceeded 3 volts (and it was how I destroyed the other two FST-01s
in previous years, that I've mentioned in the mail earlier, the culprit was not
ESD but some hidden trap in my broken ST-Link clone?)

Today, I tried to use my Raspberry Pi as a SWD programmer by bitbanging, OpenOCD
was also to detect the presence of the device, but trapped into a infinite loop of
SWD handshaking as soon as SWD was detected.

I don't know if it's related to Gnuk. But I found that for cheap ST-Link clones,
it is problematic to issue RESET commands under some circumstances, like sleep

Tom Li
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 851 bytes
Desc: Digital signature
URL: <>

More information about the Gnuk-users mailing list