Gnuk upgrade

Andrius Štikonas andrius at
Wed Sep 19 10:52:16 CEST 2018

I am getting the error
$ ./ -k 1 ../regnual/regnual.bin ../src/build/gnuk.bin
Admin password:
CRC32: ef11fc23

Traceback (most recent call last):
  File "./", line 157, in <module>
    main(wait_e, keyno, passwd, data_regnual, data_upgrade[4096:])
  File "./", line 51, in main
    gnuk = get_gnuk_device()
  File "/run/media/astikonas/home2/gnuk/tool/", line 620, in get_gnuk_device
    raise ValueError("No ICC present")
ValueError: No ICC present

On Wed, Sep 19, 2018 at 08:44:16AM +0900, NIIBE Yutaka wrote:
> Andrius Štikonas via Gnuk-users <gnuk-users at> wrote:
> > I tried upgrade_by_passwd too but it didn't work. This was actually
> > the first thing I tried... Well, my gnuk firmware wasn't factory
> > firmware.
> My theory is like this:
> (1) Your first try by failed by some other reason.
> (2) Your second try by failed because you
>     repeat writing to the slot 0.  The slot 0 for public key was written
>     by the process of (1) already.  In this situation, writing to the
>     slot again results GPG_MEMORY_FAILURE (the error code of 0x6581),
>     because the place can be only written once.
> Please do not use lower level tool like,
> unless you don't know the detail.  Please use
> instead.
> I suggest to identify the original issue, if you have a record of your
> trial.  If not, please try with the option '-k' to
> specify another slot 1, you must record all the session, this time.
> Then, please examine your problem in the record and fix your issue(s) at
> first.  After you will fix your issue, you can try
> with the option '-k' specifying slot 2, again.
> Please note that there are only four slots (0, 1, 2, and 3) available
> and all are write-once.  You can only fail one more time.
> -- 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: not available
URL: <>

More information about the Gnuk-users mailing list