Gnuk upgrade

NIIBE Yutaka gniibe at
Wed Sep 19 01:44:16 CEST 2018

Andrius Štikonas via Gnuk-users <gnuk-users at> wrote:
> I tried upgrade_by_passwd too but it didn't work. This was actually
> the first thing I tried... Well, my gnuk firmware wasn't factory
> firmware.

My theory is like this:

(1) Your first try by failed by some other reason.

(2) Your second try by failed because you
    repeat writing to the slot 0.  The slot 0 for public key was written
    by the process of (1) already.  In this situation, writing to the
    slot again results GPG_MEMORY_FAILURE (the error code of 0x6581),
    because the place can be only written once.

Please do not use lower level tool like,
unless you don't know the detail.  Please use

I suggest to identify the original issue, if you have a record of your
trial.  If not, please try with the option '-k' to
specify another slot 1, you must record all the session, this time.
Then, please examine your problem in the record and fix your issue(s) at
first.  After you will fix your issue, you can try
with the option '-k' specifying slot 2, again.

Please note that there are only four slots (0, 1, 2, and 3) available
and all are write-once.  You can only fail one more time.

More information about the Gnuk-users mailing list