Gnuk upgrade

Andrius Štikonas andrius at
Tue Sep 18 12:10:17 CEST 2018


I am currently using the latest git version (1.2.10). Initially device had neug and neug->gnuk flashed just fine.
I wanted to recompile it with factory reset support. Other than that device works fine for me.

I tried upgrade_by_passwd too but it didn't work. This was actually the first thing
I tried... Well, my gnuk firmware wasn't factory firmware.

And sorry for the duplicate first email.


2018 m. rugsėjo 18 d., antradienis 09:13:42 BST Szczepan Zalega | Nitrokey rašė:
> On 09/17/2018 09:51 PM, Andrius Štikonas via Gnuk-users wrote:
> > I was trying to upgrade firmware of my gnuk token. One of the steps in
> > the upgrade guide is registering a public rsa2048 key with the token.
> > 
> > However, when I run that command, I get the following error
> > 
> > Does anybody know what I am doing wrong? Neither scdaemon nor pcscd is running.
> Hi!
> Log indicates update script has connected, but device returned error
> 6581. What GNUK version are you using currently?
> Have you tried `` [1], as in:
> ./ regnual.bin gnuk.bin
> [1] Nitrokey Start upgrade help page, which is based on GNUK:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the Gnuk-users mailing list