[git] GnuPG - branch, master, updated. gnupg-2.1.10-78-ge70f7a5

by Werner Koch cvs at cvs.gnupg.org
Tue Jan 5 14:00:31 CET 2016


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "The GNU Privacy Guard".

The branch, master has been updated
       via  e70f7a54f29d727def2cfe9ea5ab9d461b4ce842 (commit)
       via  f2ecbf7454fe1e4b87112b982d7ddcd496ebc1ff (commit)
      from  ff3b607fc879b70665c187500022cc63e2a0cd86 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit e70f7a54f29d727def2cfe9ea5ab9d461b4ce842
Author: Werner Koch <wk at gnupg.org>
Date:   Tue Jan 5 13:49:06 2016 +0100

    gpg: Align notes about minimal keysize with actual checks.
    
    * g10/keygen.c (ask_keysize): Use 768 for the minimal value for DSA in
    export mode.  Improve readability.
    --
    
    GnuPG-bug-id: 2209
    Signed-off-by: Werner Koch <wk at gnupg.org>

diff --git a/g10/keygen.c b/g10/keygen.c
index 992e572..921e938 100644
--- a/g10/keygen.c
+++ b/g10/keygen.c
@@ -2006,15 +2006,13 @@ ask_algo (ctrl_t ctrl, int addmode, int *r_subkey_algo, unsigned int *r_usage,
 static unsigned
 ask_keysize (int algo, unsigned int primary_keysize)
 {
-  unsigned int nbits, min, def = DEFAULT_STD_KEYSIZE, max=4096;
+  unsigned int nbits;
+  unsigned int min = 1024;
+  unsigned int def = DEFAULT_STD_KEYSIZE;
+  unsigned int max = 4096;
   int for_subkey = !!primary_keysize;
   int autocomp = 0;
 
-  if(opt.expert)
-    min=512;
-  else
-    min=1024;
-
   if (primary_keysize && !opt.expert)
     {
       /* Deduce the subkey size from the primary key size.  */
@@ -2029,9 +2027,11 @@ ask_keysize (int algo, unsigned int primary_keysize)
       goto leave;
     }
 
+  /* Deviations from the standard values.  */
   switch(algo)
     {
     case PUBKEY_ALGO_DSA:
+      min = opt.expert? 768 : 1024;
       def=2048;
       max=3072;
       break;
@@ -2048,10 +2048,6 @@ ask_keysize (int algo, unsigned int primary_keysize)
       def=255;
       max=441;
       break;
-
-    case PUBKEY_ALGO_RSA:
-      min=1024;
-      break;
     }
 
   tty_printf(_("%s keys may be between %u and %u bits long.\n"),

commit f2ecbf7454fe1e4b87112b982d7ddcd496ebc1ff
Author: Werner Koch <wk at gnupg.org>
Date:   Wed Dec 30 18:23:14 2015 +0100

    agent: Typo fix for help text.
    
    --

diff --git a/agent/command.c b/agent/command.c
index 718a5e6..a09da60 100644
--- a/agent/command.c
+++ b/agent/command.c
@@ -2036,7 +2036,7 @@ static const char hlp_import_key[] =
   "no arguments but uses the inquiry \"KEYDATA\" to ask for the actual\n"
   "key data.  The unwrapped key must be a canonical S-expression.  The\n"
   "option --unattended tries to import the key as-is without any\n"
-  "re-encryption.  Exisiting key can be overwritten with --force.";
+  "re-encryption.  Existing key can be overwritten with --force.";
 static gpg_error_t
 cmd_import_key (assuan_context_t ctx, char *line)
 {

-----------------------------------------------------------------------

Summary of changes:
 agent/command.c |  2 +-
 g10/keygen.c    | 16 ++++++----------
 2 files changed, 7 insertions(+), 11 deletions(-)


hooks/post-receive
-- 
The GNU Privacy Guard
http://git.gnupg.org




More information about the Gnupg-commits mailing list