GPG-PGP5 Interoperation

Markus Gruber Markus.Gruber at
Thu Jul 23 19:48:43 CEST 1998


I now tried key generation as you described it and it worked (identifier 16 
instead of 20).
I put my gpg public key on pgp5's public key ring and vice versa.
I  signed and encrypted a message with pgp5 to gpg and gpg was able to read 
and verify it.

Then I signed a message with gpg to pgp5 following your suggestion...

> For now use "-z 0" to sign.  Two reasons:
>   - PGP 5 does not know how to handle compress algorithm 2
>   - May be it is not valid to pack all stuff in a compressed packet at
>     all (I have to check this) 

Pgp5 was not able to read it.

markus at poro:/opt/home/markus > gpg -z 0 -sa testfile
gpg (GNUPG) 0.3.2; Copyright (C) 1998 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

gpg: Warning: using insecure memory!

You need a passphrase to unlock the secret key for
user: "Markus Gruber (This is me) <markus.gruber at>"
(1024-bit DSA key, ID 9B8F1000, created 1998-07-23)

markus at poro:/opt/home/markus > pgpv testfile.asc
Opening file "/dev/null" type text.
markus at poro:/opt/home/markus > [This information en mass means pgpv failed]
> As soon as we have preferences work it should be much easier.
> You may add "--compress-algo 1" to your ~/.gnupg/options

Has gpg compress-algo 1 (ZIP) implemented yet or does is there only ZLIB?

I also tried the following:
gpg --compress-algo 1 -eat testfile

The same ascetic fault message with pgpv as above.

Another thing I did: I signed the pgp5 public key on the gpg-keyring. The 
signature got added, as I could see with gpgm --list-sigs, but the key didn't 
get trusted. What can I do to have gpg trust the key by default?


More information about the Gnupg-devel mailing list