--yes option working?

Karl Fogel kfogel at floss.onshore.com
Thu May 21 21:20:16 CEST 1998

I ran into this problem while implementing an Emacs interface to
GNUPG (which I will post as soon as its ready):

When I run the following command (for an addressee who is NOT in the
trust database):

   gpg -a -r "Ben Sussman" --batch --yes -o - -e < z

I get this output:

   gpg: Warning: using insecure memory!
   gpg: no info to calculate a trust probability
   gpg: no valid addressees
   gpg: [stdin]: encryption failed: No such user id

Okay.  So I removed the "--batch" flag, and got this:

   Could not find a valid trust path to the key.  Let's see whether we
   can assign some missing owner trust values.
   No ownertrust values changed.
   It is NOT certain that the key belongs to its owner.
   If you *really* know what you are doing, you may answer
   the next question with yes
   Use this key anyway? 

I had thought that GPG would assume the answer to be "yes", since I
passed the "--yes" flag, but it prompted me anyway.

What to do?


More information about the Gnupg-devel mailing list